ChinaHost

 找回密码
 用户.注册
查看: 4102|回复: 1

[VPS经验交流] Ubuntu错误:Unmet dependencies. Try 'apt-get -f install' with no packages ...

[复制链接]
发表于 2012-7-25 17:18:24 | 显示全部楼层 |阅读模式
本帖最后由 挖土机 于 2012-7-25 23:33 编辑

出现的错误如下:

You might want to run apt-get -f install to correct these:
the following packages have unmet dependencies:
libudev0: Depends: udev (= 151-3) but 0.125-7+lenny3 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
E: apt-get failed



其解决办法如下:
  1. 01 apt-get update
  2. 02 apt-get dist-upgrade
  3. 03 apt-get update
  4. 04 apt-get dist-upgrade
  5. 05 touch /etc/udev/kernel-upgrade
  6. 06 dpkg -i /var/cache/apt/archives/udev_151-3_i386.deb
  7. 07 apt-get dist-upgrade -f
复制代码
出现安装的过程一路默认即可。
成功后,在安装tomcat
  1. apt-get install tomcat6
复制代码
成功。
发表于 2013-1-25 11:16:15 | 显示全部楼层
我只是路过,不发表意见
您需要登录后才可以回帖 登录 | 用户.注册

本版积分规则

手机版|小黑屋|

Processed in 0.079634 second(s), 20 queries , Gzip On.

Powered by Comsenz Discuz! platform.

© 2012-2016 中国主机联盟 专业IDC交流平台,提供服务器、VPS云主机、虚拟主机、域名技术交流及优惠信息

快速回复 返回顶部 返回列表